В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mssvetochkaki
mssvetochkaki
01.05.2021 20:38 •  Информатика

Написать программу на фортране
определить,является ли заданная матрица 5 порядка ортонормированной.

Показать ответ
Ответ:
sashamenkov18
sashamenkov18
30.09.2022 23:00

const g = 5; v = 3;

var a: array[1..g,1..v] of integer;

i,j,maxj,minj,p:integer;

begin

writeln('Массив: ');

for i:=1 to g do

begin

for j:=1 to v do

begin

a[i,j]:=Random(101);

write(a[i,j]:4)

end;

writeln

end;

for i:=1 to g do

begin

maxj:=1;

minj:=1;

for j:=1 to v do

begin

if a[i,j]>a[i,maxj] then maxj:=j;

if a[i,j]<a[i,minj]then minj:=j;

end;

p:=a[i,maxj];

a[i,maxj]:=a[i,minj];

a[i,minj]:=p;

end;

writeln;

writeln('Преобразованный массив: ');

for i:=1 to g do

begin

for j:=1 to v do write(a[i,j]:4);

writeln

end;

end.

0,0(0 оценок)
Ответ:
lowrentij
lowrentij
30.09.2022 23:00

var i,j,max,min,imax,imin:integer; A:array[0..5,0..3] of integer;

begin  

min:=101;

Randomize;

for i:=0 to 5 do begin

for j:=0 to 3 do begin

A[i,j]:= random(100);

write(A[i,j]:3);

end;writeln;

end;

writeln;writeln;

for i:=0 to 5 do begin

for j:=0 to 3 do begin

if A[i,j] > max then begin max:= A[i,j];imax:=j;end;

if A[i,j] < min then begin min:= A[i,j];imin:=j;end;

end;

A[i,imin]:=max;

A[i,imax]:=min;

max:=0;min:=101;

imin:=0;imax:=0;

end;

writeln;

for i:=0 to 5 do begin

for j:=0 to 3 do begin

write(A[i,j]:3);

end;writeln;

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота