В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
AlinaMalina1011
AlinaMalina1011
12.05.2020 20:53 •  Информатика

Написать программу на free pascal которая переводит число из десятичной системы в двоичную

Показать ответ
Ответ:
liol456543
liol456543
12.07.2020 11:28
Function ToBinaryString(x: integer): string;
var r, s: string;
begin
  if x < 0 then begin
    s := '-';
    x := -x;
  end;
  while x <> 0 do begin
    r := Chr((x and 1) or 48) + r;
    x := x shr 1;
  end;

  ToBinaryString := s + r;
end;

var x: integer;
begin
  readln(x);
  writeln(ToBinaryString(x));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота