В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
09Катя99
09Катя99
17.02.2023 03:45 •  Информатика

Написать программу на лазарусе, которая считает, сколько раз встречается определенный символ в строке. Первая строка ввода программы - это слово или предложение. Вторая строка - это символ. Вывод программы этот символ в нижнем регистре, знак равно и число, сколько раз он встречается в первой строке. Символы нижнего и верхнего регистра считать одинаковыми F=f, a=A и.т.д, поэтому удобно и сами входные данные и символ перевести в нижний регистр (LowerCase). Delphi.

Показать ответ
Ответ:
Tililinka
Tililinka
20.08.2021 01:32

function F(x: real): real;

begin

 F := 3 * sin(x) + 2 * sqr(x) - 1;

end;

var

 a, b, h, x, Fa, Fx: real;

begin

 Write('Введите через пробел начало интервала, конец и шаг: ');

 Readln(a, b, h);

 x := a; Fa := F(a);

 repeat

   Fx := F(x);

   if Fx = 0 then Writeln('Найден корень ', x:0:3)

   else

   if Fx * Fa < 0 then

     Writeln('Найден интервал изоляции корня (', a:0:3, ';', x:0:3, ')');

   a := x; Fa := Fx; x := x + h

 until x > b;

end.

Тестовое решение:

Введите через пробел начало интервала, конец и шаг: 0 1.95 0.15

Найден интервал изоляции корня (0.150;0.300)

Введите через пробел начало интервала, конец и шаг: -5 5 0.1

Найден интервал изоляции корня (-1.500;-1.400)

Найден интервал изоляции корня (0.200;0.300)

Объяснение:

Лови! Удачки!
0,0(0 оценок)
Ответ:
mtmrfz43
mtmrfz43
17.04.2023 09:15

Объяснение:

2. Линейный алгоритм это -  алгоритм без ветвлений и повторений, описывающий последовательное выполнение действий

3. ('информация', 1, 19, 29)

4.

Инструменты автоматизации  сборки - Процесс связывания всех файлов, созданных  компилятором, с исполняемым файлом

Коррекция / отладка - приложение для пошагового поиска, обнаружения и  исправления программных ошибок

Компилятор / интерпретатор - перевод программного обеспечения в машинный код

Текстовый редактор - главное окно, куда вставляется программный код.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота