В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
maximkh1
maximkh1
30.10.2021 19:39 •  Информатика

Написать программу на pacal abc и составить блок-схему этой программы. : проверить истинность высказывания: "все цифры данного трехзначного числа различны" программа должна выводить либо true либо false. (с типа: boolean) зараннее !

Показать ответ
Ответ:
ВиГуки247
ВиГуки247
17.06.2020 13:47

uses crt;
var
  x:integer;
  y:boolean;
begin
  clrscr;
  write('Введите трехзначное число'); read(x);
  y:=((x mod 10)<>(x div 100))and
   ((x div 100)<>(x mod 100 div 10))and
   ((x mod 10)<>(x mod 100 div 10));
  write(y);
end.


Написать программу на pacal abc и составить блок-схему этой программы. : проверить истинность высказ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота