В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Оксана1970
Оксана1970
03.02.2022 19:09 •  Информатика

Написать программу на pascal: дан массив вещественных чисел. проверить, является ли данный массив палиндромом. стандартные методы и срезы использовать нельзя.

Показать ответ
Ответ:
dmatveeva1
dmatveeva1
23.02.2021 02:43
Var
  i, j, n, kolPol, kolOtr, sum, p, ch, k :integer;
  a :array of integer;

begin

  readln(n);
  SetLength(a,n+1);
  randomize;
  for i:= 1 to n do
    a[i]:= random(100)-50;
 
  sum:= 0; p:= 1;
  for i:= 1 to n do
  begin
    if a[i] > 0 then
    begin
      inc(kolPol);
      sum:= sum + a[i];
    end;
    if a[i] > 0 then
    begin
      inc(kolOtr);
      p:= p * a[i];
    end;
  end;
 
  writeln('Количество положительных элементов: ',kolPol);
  writeln('Сумма положительных элементов: ',sum);
  writeln('Количество отрицательных элементов: ',kolOtr);
  writeln('Произведение отрицательных элементов: ',p);
 
  i:= 1; p:= 1; ch:= 0;
  while (a[i] >= 0) and (i <> n+1) do
  begin
    p:= p * a[i];
    inc(ch);
    inc(i);
  end;
 
  if ch <> 0 then 
    writeln('Произведение до первого отрицательного элемента: ',p)
  else
    writeln('Первый элемент массива отрицательный!');
   
  for i:= 1 to n-1 do
    for j:= 1 to n-i do
      if a[j] > a[j+1] then
      begin
        k:= a[j];
        a[j]:= a[j+1];
        a[j+1]:= k;
      end;
  writeln('Массив отсортирован по возрастанию:');
  for i:= 1 to n do
    write(a[i],'  ');

end.
0,0(0 оценок)
Ответ:
gogaefremkov
gogaefremkov
20.08.2021 19:21
Порядок неубывания,значит порядок возрастания.
2828 не может,так как если мы введём максимальное число 99999,то будет 2727
2512 не может, так как порядок возрастания,а 25>12
2518 не может, так как порядок возрастания,а 25>18
2524 не может, так как порядок возрастания,а 25>24
2425 может(число 78997)
1825 может(число 72979)
1225 может(число 12979)
123 не может,существует 2 варианта записи этого числа:
1)12 и 3,но такого быть не может,так как 12>3
2)1 и 23,но такого быть не может,так как чтобы получилось 23 должны быть числа больше 7,а 1 получается слева,значит среднее число максимум 1,но нам оно не подходит
Итак,подходят 2425,1825,1225
ответ: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота