В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
7575757575
7575757575
21.10.2020 20:23 •  Информатика

Написать программу на паскаль абц которая решит данное выражение.
какое значение будет упеременных x,y,z не важно

Показать ответ
Ответ:
kannaaa
kannaaa
08.02.2023 08:23

var
j, k, l, m : Word;
A : array [0..27] of Integer; {27 потому что максимальная сумма трех цифр 27, т.е. 9+9+9}
begin
ClrScr;
Writeln ('счастливый билет');
for j:=1 to 27 do A[j]:=0;
for j:=0 to 9 do
for k:=0 to 9 do
for l:=0 to 9 do
A[j+k+l] := A[j+k+l] + 1;

m := 0;
for j:=0 to 27 do
m := m + A[j]*A[j];

WriteLn(m);

ReadLn; {это чтобы увидеть результат}
end.

А если требуется все-таки "лобовое", то можно так

m := 0;
for k:=0 to 999999 do begin
Str(k, SS);
SS := Copy('000000', 1, 6 - Length(SS)) + SS; {дополняем слева нулями при необходимости}
if (Ord(SS[1])-48+Ord(SS[2])-48+Ord(SS[3])-48) = (Ord(SS[4])-48+Ord(SS[5])-48+Ord(SS[6])-48) then
Inc(m);
end;

Остальное сами.

0,0(0 оценок)
Ответ:
kamillionela
kamillionela
21.01.2023 08:08

Program A1;
var a:array[1..30] of integer;
      amax,amin,i,imin,imax,n,s:integer;
begin
writeln('введите n элементов массива');
readln(n);
for i:=1 to n do a[i]:=random(30);
writeln('введённый массив имеет вид');
for i:=1 to n do write(a[i], '  ');
writeln;
amax:=a[1]; imiax:=1;
for i:=2 to n do 
if a[i]>amax then begin amax:=a[i]; imax:=i; end;
amin:=a[1]; imin:=1;
for i:=2 to n do 
if a[i]<amin then begin amin:=a[i]; imin:=i; end;
writeln('полученный массив имеет вид');
s:=a[imin];

a[imin]:=a[imax];

a[imax]:=s;
for i:=1 to n do 
writeln(a[i],'  ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота