В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу на паскаль, которая будет узнавать лежит ли точка в закрашенной области
должно выводить 3 ответа к 3-м графикам.
пример указан на фото:
x,y = 2,0
к 1-му графику нет
к остальным 2-м да

Показать ответ
Ответ:
МаКсИк009
МаКсИк009
30.06.2020 10:49

Python

Объяснение:

код:

import random

n = random.randint(10, 100)

t = []

p = []

for i in range(1, n):

   if n % i == 0:

       i = str(i)

       t += i

       i = int(i)

       for k in range(2, i):

           if i % k == 0:

               i = str(i)

               p += i

               break

t = list(map(int, t))

p = list(map(int, p))

for x in p:

   if x in t:

       t.remove(x)

t.remove(1)

if len(t) == 0:

   t.append(n)

   print(*t)

else:

   s = [str(x) for x in t]

   print('simple', '(', n, ')', '=', *s)

0,0(0 оценок)
Ответ:
rozik080
rozik080
30.06.2020 10:49

Python

Объяснение:

код:

import random

n = random.randint(10, 100)

t = []

p = []

for i in range(1, n):

   if n % i == 0:

       i = str(i)

       t += i

       i = int(i)

       for k in range(2, i):

           if i % k == 0:

               i = str(i)

               p += i

               break

t = list(map(int, t))

p = list(map(int, p))

for x in p:

   if x in t:

       t.remove(x)

t.remove(1)

if len(t) == 0:

   t.append(n)

   print(*t)

else:

   s = [str(x) for x in t]

   print('simple', '(', n, ')', '=', *s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота