В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
daallantin
daallantin
04.10.2022 22:05 •  Информатика

Написать программу на Паскале

1. Алгоритм вычисления абсолютной величины действительного числа.
алг вещ аbs (вещ x)
нач
если x >=0
то знач:=x
иначе знач:=-x
все
кон

2. Алгоритм нахождения максимальной из двух величин.
алг вещ max 2 (вещ а,b)
нач
если а >=b
то знач:= а
иначе знач:=b
все
кон

3. Алгоритм решения квадратного уравнения аx2+bx+с=0, где а,b,с – произвольные вещественные числа (а≠0)
алг КВУР (вещ а,b,с, вещ x1, x2, лит y)
арг а,b,с
рез x1, x2, y
нач
вещ D
D:= b2-4ас
если D<0
то y:= «нет решения»
иначе
y:= «есть решения»
x1:=(-b+√D)/2а
x2:=(-b-√D)/2а
все
кон

4. Алгоритм Евклида вычисления наибольшего общего делителя двух натуральных чисел.
алг вещ НОД (нат m,n)
нач
нат x, y
x:= m
y:= n
пока x≠y
нц
если x >y
то x:= x- y
иначе y:= y-x
все
кц

Показать ответ
Ответ:
VPVolkov03
VPVolkov03
26.01.2022 05:16

Ваша программа:

mas = [3,5,67,-65,34,21] # задаем список

print(mas)

point=3 # задаем искомое значение

l = len(mas) # вычисляем длину списка (количество элементов)

for i in range( l ):

   if mas [i]==point:

       print("Содержит")

       break

   else:

       print ("Не содержит")

Можно ещё так записать:

mas = [3,5,67,-65,34,21] # задаем список

print(mas)

point=3 # задаем искомое значение

for i in mas: #смотрим каждый элемент в массиве

   if i == point:

       print("Содержит")

       break

   else:

       print ("Не содержит")

Можно написать так, что более понятно:

mas = [3,5,67,-65,34,21] # задаем список

print(mas)

point=3 # задаем искомое значение

if point in mas:

   print("Содержит")

else:

   print ("Не содержит")


Поиск заданного элемента в списке mas = [3,5,67,-65,34,21] # задаем списокprint(mas) ………………………………… [
0,0(0 оценок)
Ответ:
LuckyZhenya
LuckyZhenya
06.02.2021 10:18
Код:

#include <iostream>

using namespace std;

int main()

{

   int n,i,max,j,count=0,sum=0;

   cout << "n = ";

   cin >> n;

   int array[n];

   for (i=0;i<n;i++)

   {

       cin >> j;

       if (j>1000000)

       {

           cout << "Элемент массива превосходит 1000000";

           break;

       }

       else

       {

           array[i] = j;

           sum += j;

       }

   }

   max = array[0];

   for (i=1;i<n;i++)

   {

       if (array[i]>max)

       {

           max = array[i];

       }

   }

   for (i=0;i<n;i++)

   {

       if (array[i] == max)

       {

           count++;

       }

   }

   if (count > 1)

   {

       sum -= count*max;

       cout << "Сумма элементов массива без максимальных: " << sum;

   }

   else

   {

       sum -= max;

       cout << "Сумма элементов массива без максимального: " << sum;

   }

}  

Вывод:

n = 5                                                                                                                          

1 2 5 3 5                                                                                                                      

Сумма элементов массива без максимальных: 6  

1 + 2 + 3 = 6

n = 5                                                                                                                          

1 2 3 4 5                                                                                                                      

Сумма элементов массива без максимального: 10      

1 + 2 + 3 + 4 = 10  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота