В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
likewithboss
likewithboss
19.01.2020 07:29 •  Информатика

Написать программу на паскале авс. светофор переключается каждые 10 секунд. в 0 часов 0 минут 0 секунд горит зелёный. какой цвет будет гореть через 4 часа 5 минут 23 секунды

Показать ответ
Ответ:
mogilko88
mogilko88
11.06.2020 11:46

var
  timeInSec:integer; // время в секундах
  color, s, m, h:byte;
begin
  h := 4; //часы
  m := 5; //минуты
  s := 23; //секунды

  timeInSec := h * 3600 + m * 60 + s; //перевод времени в секунды
  color := (timeInSec div 10) mod 3; {целочисленно делим на 10, чтобы узнать сколько раз светофор изменил цвет}
  {потом находим остаток деления на 3(количество цветов), чтобы узнать какой сейчас   цвет}
  case color of //вывод ответа
    0: writeln('Горит зеленый свет'); //0 - это зеленый свет
    1: writeln('Горит желтый свет'); //1 - это желтый свет
    2: writeln('Горит красный свет'); //2 - это крсный свет
  end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота