В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ksskjskdjdkdk
ksskjskdjdkdk
24.06.2022 06:10 •  Информатика

Написать программу на паскале: даны 3 числа, если это куб-найти объём, если это параллелепипед-найти площадь поверхности

Показать ответ
Ответ:
peterburg1
peterburg1
09.10.2020 22:32

var a,b,c,k: real;

begin

write('Введите 1 число: ');

readln(a);

write('Введите 2 число: ');

readln(b);

write('Введите 3 число: ');

readln(c);

if (a=b) and (b=c) and (a=c) then

begin

k:=a*b*c;

writeln('Объем куба равен ',k);

end else

begin

k:=2*(a*b+b*c+a*c);

writeln('Площадь поверхности параллелипипеда равна ',k);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота