В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
romababiy09
romababiy09
04.09.2022 02:14 •  Информатика

написать программу на Паскале для решения данной задачи или хотя бы подскажите алгоритм решения.
Дано три натуральных числа, не превышающих 32767. Определить, сколько из них имеют одинаковое количество цифр.

Показать ответ
Ответ:
vladbochilo
vladbochilo
13.05.2023 07:41
1, 2)
Сначала надо разделить IP на байты, по 8 бит:
1 )11001100.11100010.10100110.01101001
2) 11011001.10100001.01100011.00111010

Теперь переводим каждый байт в десятичную сс, получаем:

1) 204.226.166.105
2) 217.161.99.58

3, 4) 
Переведем каждый байт в двоичную сс:

3) 10111100.1011.11000010.100000
4) 11110000.1111.0.10

Добавим незначащие нули, чтобы кол-во бит в каждом байте было равно восьми:

3) 10111100.00001011.11000010.00100000
4) 11110000.00001111.00000000.00000010

Уберем точки:

3) 10111100000010111100001000100000
4) 11110000000011110000000000000010
0,0(0 оценок)
Ответ:
tanusik32
tanusik32
05.02.2020 11:33
#include <iostream>
#include <cstring>

using namespace std;

int main() {
    int n,m;
    cin >> n >> m;
    int a[n][m], sn[n], sm[m]; //sn - сумма строк, sm  - сумма столбцов
    memset(sn, 0, n*sizeof(int));
    memset(sm, 0, m*sizeof(int));
    for(int i = 0; i < n; i++)
        for(int j = 0; j < m; sn[i]+= a[i][j], sm[j]+= a[i][j], j++)
            cin >> a[i][j];
    cout << endl;
    for(int i = 0; i < n; i++) cout << sn[i] << ' ';
    cout << endl << endl;
    for(int i = 0; i < m; i++) cout << sm[i] << ' ';
    cout << endl << endl;
    for(int i = 0; i < n; i++) {
        for(int j = 0; j < m; j++)
            cout << a[i][j] << ' ';
        cout << endl;
    }   
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота