В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
разетка1234
разетка1234
06.02.2022 20:32 •  Информатика

Написать программу на паскале известен рост каждого ученика в классе.рост мальчиков условно задан отрицательными числами. определить средний рост мальчиков и средний рост девочек.

Показать ответ
Ответ:
нина503
нина503
05.10.2020 15:16
Var n, i, growth, growth_girls, growth_boys, count_boys, count_girls: integer;
begin
writeln('Введите количество учеников в классе');
read(n);

growth_girls := 0;
growth_boys := 0;
count_boys := 0;
count_girls := 0;
for i := 1 to n do
begin
  read(growth);
  if (growth < 0) then
  begin
    growth_boys := growth_boys - growth;
    count_boys := count_boys + 1;
  end
  else
  begin
    growth_girls := growth_girls + growth;
    count_girls := count_girls + 1;
  end;
end;

if (count_boys = 0) then
  writeln('В классе нет мальчиков')
else
  writeln('Средний рост мальчиков: ', (growth_boys / count_boys):0:2);

if (count_girls = 0) then
  writeln('В классе нет девочек')
else
  writeln('Средний рост девочек: ', (growth_girls / count_girls):0:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота