В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
icon21
icon21
05.11.2021 10:04 •  Информатика

Написать программу на паскале, которая формирует случайным образом массив из n- целых чисел, лежащих в диапозоне от 1 до 5, вывести сма массив и номера элементов с первым элементом.

Показать ответ
Ответ:
алгебра97
алгебра97
14.06.2020 13:19

program zadanie;
var
a: array[1..99999] of real;
i,n: integer;
begin
randomize;
write('Введите число чисел массива: '); readln(n);
for i:=1 to n do
begin
a[i]:=1+random(5);
writeln('a[', i, ']=', a[i]);
end;
write('Номера элементов, совпадающих с первым элементом: ');
for i:=1 to n do if a[i+1]=a[1] then write(i+1:3);
writeln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота