В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
abakanilaha
abakanilaha
08.02.2020 20:41 •  Информатика

Написать программу на Паскале, которая выведет на экран, учебное заведение,
гапоу со карпинский машиностроительный техникум

Показать ответ
Ответ:
лол1634
лол1634
10.12.2022 19:51
1) 7  - изза начального присвоение m
2) 994. 4 соответствует условию, остальные числа лишь максимизируют число
3)

var
    N, d, m: longint;

begin
    readln(N);
    {m := N mod 10; ошибочная строка}
    m:=-1; {N mod 10 - может не удовлетворять условию, 0 - может и удовлетворять условию }
    while N > 0 do
    begin
        d := N mod 10;
        if d < 5 then
            if d > m then m := d;
        N := N div 10;
    end;
    {if m = 0 then ошибочная строка}
    if m = -1 then {если в цикле m так не разу и не поменялась}
        writeln('NO')
    else writeln(m);
end.
0,0(0 оценок)
Ответ:
gancedag05
gancedag05
30.04.2022 21:22
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

function DecToa(n:string;k:integer):string;
// Перевод из десятичной системы в систему по основанию k
begin
  var s:='0123456789';
  Result:='';
  var PointPos:=Pos('.',n);
  var IntPart:integer;
  if PointPos>0 then begin // есть дробная часть
    var FracPart:=Frac(n.ToReal);
    var m:=0;
    while True do begin
      var r:=FracPart*k;
      Result+=s[Trunc(r)+1];
      FracPart:=Frac(r);
      m+=1;
      if (m=15) or (FracPart=0) then break
      end;
    IntPart:=n[:PointPos].ToInteger;
    end
  else IntPart:=n.ToInteger;
  if Result<>'' then Result:='.'+Result;
  while IntPart>0 do begin
    Result:=s[IntPart mod k+1]+Result;
    IntPart:=IntPart div k
    end;
  if Result='' then Result:='0';
  if Result[1]='.' then Result:='0'+Result
end;

begin
  var n:=ReadlnString('Какое число перевести?');
  var p:real;
  if not real.TryParse(n,p) then Writeln('Такая запись недопустима')
  else
    if n.Contains('e') or n.Contains('E') then
      Writeln('Запись в экспоненциальном формате не разрешена')
    else begin
      var k:=ReadInteger('Укажите основание системы:');
      if k.Between(2,36) then     
          Writeln(n,'(10) = ',n[1],DecToA(n[2:],k),'(',k,')')
      else Writeln('Допустимы основания 2..36')
      end
end.

Примеры
Какое число перевести? 123,5433
Такая запись недопустима

Какое число перевести? -353.093234
Укажите основание системы: 21
-353.093234(10) = -GH.1K2951B0DJAH1BI(21)

Какое число перевести? 6523
Укажите основание системы: 8
6523(10) = 61013(8)

Какое число перевести? 1.2e-18
Запись в экспоненциальном формате не разрешена
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота