В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
akasheva1982
akasheva1982
09.12.2020 04:00 •  Информатика

Написать программу на паскале которая запрашивает трёхзначное число, затем с функций div mod разделяет число на цифры и проверяет имеются ли в введенном числе цифра "5". если да, то печатает "имеется" иначе "не имеется

Показать ответ
Ответ:
Ксения200612
Ксения200612
07.10.2020 14:14
Var N, k, y: integer;
begin
  write('Введите число: ');
  readln(N);
  k := 0;
  repeat
    y := N mod 10;
    if y = 5 then k := k + 1;
    N := N div 10;
  until N = 0;
  if k <> 0 then writeln('Имеется')
  else writeln('Не имеется')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота