В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
weri8
weri8
08.03.2020 13:59 •  Информатика

Написать программу на паскале: найти разность между к и суммой всех элементов массива с нечетными индексами

Показать ответ
Ответ:
makstaira2203
makstaira2203
12.06.2020 12:50

Желательно в задании уточнять тип массива (целый, вещественный ) и его генерации(ввод с клавиатуры, генератор случайных чисел).

 

В данной программе массив получен с генератора случайных чисел 

 

  

Program raznost;

Uses Crt;

const n=100; {максимальный размер массива}

var a:array[1..n] of  integer; 

 

       i,m:integer;

       k,s,rez:longint;

begin

     clrscr;

     write('Введите К: ');

     readln(k);

     write('Введите размер массива <100: ');

     readln(m);

 

 

     randomize; 

     write('Исходный массив:')

 

    s:=0;

     for i:=1 to m do

          begin

               a[i]:=random(50)+25;   

 

               write(i:3);   

 

               if  (i mod 2)<>0 then s:=s+a[i];

 

           end;

     writeln;

     rez:=k-s;       

     writeln('Разность между K и суммой всех элементов массива с нечетными индексами=',rez);

     readkey;

end. 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота