В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DarPlay70
DarPlay70
05.06.2022 23:33 •  Информатика

Написать программу на паскале
рассматривается множество целых чисел, принадлежащих отрезку [200; 9120], которые делятся на 8 и не делятся на 7, 11, 17 и 19. Найдите количество таких чисел и минимальное из них. В ответе запишите два числа через пробел: сначала количество, затем минимальное число.

Показать ответ
Ответ:
HupiTip
HupiTip
13.10.2020 11:55

var cnt,min,i: integer;

begin

min:=0;

cnt:=0;

for i:=200 to 9120 do

 begin

 if (i mod 8 = 0) and (i mod 7 <> 0)

 and (i mod 11 <> 0) and (i mod 17 <> 0)

 and (i mod 19 <> 0) then  

   begin

   if (min=0) then min:=i;

   cnt:=cnt+1;

   end;

 end;

writeln(cnt,' ',min);

end.

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота