В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
situan4
situan4
09.02.2022 06:35 •  Информатика

Написать программу на паскале, ! составить программу для вычисления степеней чисел вида аⁿ, если a> maxint, n > 10.

Показать ответ
Ответ:
tatu261
tatu261
21.08.2020 15:57
// PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadlnString('Введите натуральное число a:').ToBigInteger;
  var n:=ReadInteger('Введите показатель степени n:');
  Writeln('a^n = ',a**n)
end.

Написать программу на паскале, ! составить программу для вычисления степеней чисел вида аⁿ, если a&g
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота