Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
lehayoutube
19.04.2020 07:00 •
Информатика
Написать программу на паскале : ) составить программу, проверяющую, являются ли данные три числа взаимно простыми. использовать подпрограмму.
Показать ответ
Ответ:
gallavich2004
03.10.2020 03:09
Числа являются взаимно простыми, если их наибольший общий делитель равен 1. Используя это свойство, напишем программу:
var
a, b, c: integer;
{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
while b > 0 do
begin
t := b;
b := a mod b;
a := t;
end;
gcd := a;
end;
{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
isCoprime := gcd(gcd(a, b), c) = 1;
end;
begin
read(a, b, c);
if isCoprime(a, b, c) then write('Числа взаимно простые')
else write('Числа не являются взаимно простыми');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
DekenS1
16.03.2023 20:25
Кол-во нулей в двоичной записи числа 132? 1153(8)=? (16) de7b(16)=? (8) надо к завтрашнему дню! : (...
YeezyM
16.03.2023 20:25
Программа по на нахождению y=4x/12b+10 в паскале...
teaonline
03.01.2023 22:58
Для быстрого поиска файла документ в папке надо: а. нажать клавишу с буквой д в окне папки в. однавременно нашать клавиши shift u д в окне папки с. зайти в поиски нажать клавишу...
Золушка444
23.03.2021 06:39
Какое слово зашифровано? нпеёмэ код к зашифровке - сдвиг на одну букву....
Suhih77
23.03.2021 06:39
(pascalabc). программа вводит два числа, выводит сумму их модулей...
Данил30576
05.04.2021 17:31
Синформатикой. загрузили, я не успею ее сделать просто , сделать хоть что-то.. 1. что называется временной дискретизацией? 2. от каких характеристик зависит качество звука? 3. что...
Димон123467
03.04.2021 06:52
Используя MS Excel, определи факториал числа 20. ответ: 20! =...
svetar2014
29.12.2021 18:17
Нужно составить программу в си++. вывести квадраты и кубы 10 чисел следующей последовательности: 1, 2, 4, 7, 11,...
Снежок74
14.06.2020 00:38
Нужная вам книга находится на одной из 16 полок. какое количество информации несет в себе сообщение об этом? а) 4 бита б) 3 бита в) 5 бит г) 7 бит...
lizismik15
16.05.2022 12:38
Таблица истинности: 1. (a or not b)and(a or not b) 2. a or not a and a...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
a, b, c: integer;
{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
while b > 0 do
begin
t := b;
b := a mod b;
a := t;
end;
gcd := a;
end;
{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
isCoprime := gcd(gcd(a, b), c) = 1;
end;
begin
read(a, b, c);
if isCoprime(a, b, c) then write('Числа взаимно простые')
else write('Числа не являются взаимно простыми');
end.