написать программу на питоне(в крайнем случае на паскале), которая будет считать максимальное количество подряд идущих чисел, каждое из которых больше предыдущего в последовательности 20 положительных чисел от 1 до 100
Or - "ИЛИ". Если одно из условий верно, то и все выражение принимает истину [ 0 or 1 = 1 ; 1 or 0 = 1; 1 or 1 = 0, 0 or 0 = 0], где 1 - истина, а 0 - ложь у тебя условие If(k>9) or (k<14) then условие k > 9 выполняется, а значит и все выражение верно Нужно заменить "OR" на "AND" оператор "И". [ 1 and 1 = 1 ] при всех остальных - ложь
Вот код
var k: integer; begin readln(k); if k > 17 then Writeln('ваша оценка 5. Молодец!'); if (k > 13) and (k < 18) then Writeln('ваша оценка 4.'); if(k > 9) and (k < 14) then Writeln('ваша оценка 3.'); if k < 10 then Writeln('ваша оценка 2.'); end.
у тебя условие
If(k>9) or (k<14) then
условие k > 9 выполняется, а значит и все выражение верно
Нужно заменить "OR" на "AND" оператор "И".
[ 1 and 1 = 1 ] при всех остальных - ложь
Вот код
var
k: integer;
begin
readln(k);
if k > 17 then
Writeln('ваша оценка 5. Молодец!');
if (k > 13) and (k < 18) then
Writeln('ваша оценка 4.');
if(k > 9) and (k < 14) then
Writeln('ваша оценка 3.');
if k < 10 then
Writeln('ваша оценка 2.');
end.
ответ: 2 ВАРИАНТ)
var
x:real;
begin
x:=(32+45)/(2+7);
writeln('x=',x:4:2);
readln;
end.
Объяснение:
1 ВАРИАНТ)
var
x:char;
begin
x:=(32+45)/(2+7);
writeln('x=',x:4:2);
readln;
end.
НЕ ПОДХОДИТ, Т.К. для x указан тип данных - символьный. var x:char;
2 ВАРИАНТ)
var
x:real;
begin
x:=(32+45)/(2+7);
writeln('x=',x:4:2);
readln;
end.
ПОДХОДИТ, Т.К. всё верно.
3 ВАРИАНТ)
var
x:real;
begin
x:=(32+45)/(2+7);
end.
НЕ ПОДХОДИТ, Т.К. программа не делает вывод ответа.
4 ВАРИАНТ)
var
x:real;
begin
x:=(32+45)*(2+7);
writeln('x=',x:4:2);
readln;
end.
НЕ ПОДХОДИТ, Т.К. допущена ошибка при записи уравнения. Указано умножение, вместо деления (32+45) * (2+7)