В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pstepanova496
pstepanova496
23.12.2020 03:58 •  Информатика

написать программу на С++ Дано целое число N (> 1), являющееся числом Фибоначчи: N = FK Последовательность чисел Фибоначчи FK определяется следующим образом:
F1 = 1, F2 = 1, FK = FK−2 + FK−1, K = 3, 4, . . . .
Найти целое число K — порядковый номер числа Фибоначчи N

Показать ответ
Ответ:
Виолетта2018
Виолетта2018
02.11.2022 18:26

1.

а) 512 Мбайт = 512 * 8 Мбит = 4096 Мбит

б) 32 Кбайт = 32 * 8 Кбит = 256 Кбит

2.

а) 32 Мбит = 32 : 8 Мбайт = 4 Мбайт

б) 1024 Кбит = 1024 : 8 Кбайт = 128 Кбайт

3. Все зависит от кодировки. Если 1 символ занимает 1 байт, тогда сообщение будет занимать столько байт, сколько символов в сообщении (буквы, пробелы, точки и любые другие символы) - в данном случае - 20 байт.

Если же 1 символ занимает 2 байта (к примеру в кодировке юникод UTF-16), тогда сообщение будет занимать 40 байт.

4. 4 гигабайта = 4096 Мбайт.

4096 / 2 = 2048 картинок поместится на флешке размером 4 гигабайт


Последний вопрос не понял. Посчитать 2 в 32 степени?

0,0(0 оценок)
Ответ:
BrainS711
BrainS711
22.02.2021 18:40
Program Pas02;
uses Crt;
const
  n=20;
var
  a:array[1..n] of real;
  i,k:integer;
  t:real;
begin
  Randomize;
  ClrScr;
  Writeln('Массив случайных чисел');
  k:=0;
  for i:=1 to n do begin
    a[i]:=Random(31)-15.0;
    Write(a[i]:6:1);
    if a[i]=10.0 then Inc(k)
    end;
  Writeln;
  Writeln('Количество элементов, равных 10: ',k);
  Write('Нулевые элементы ');
  k:=0;
  for i:=1 to n do
    if a[i]=0 then begin Inc(k); Write(i,' ') end;
  if k=0 then Writeln('отсутствуют') else Writeln;
  Writeln('Меняем местами элементы 3 и 6');
  t:=a[3];
  a[3]:=a[6];
  a[6]:=t;
  for i:=1 to n do
    Write(a[i]:6:1);
  Writeln
end.

Тестовое решение
Массив случайных чисел
   2.0 -12.0   8.0  -2.0  -1.0   3.0 -12.0  -9.0   3.0   9.0  -8.0   0.0  -7.0  -4.0 -12.0  10.0   9.0   5.0  -8.0   6.0
Количество элементов, равных 10: 1
Нулевые элементы 12
Меняем местами элементы 3 и 6
   2.0 -12.0   3.0  -2.0  -1.0   8.0 -12.0  -9.0   3.0   9.0  -8.0   0.0  -7.0  -4.0 -12.0  10.0   9.0   5.0  -8.0   6.0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота