Написать программу на С++, которая: -предлагает пользователю ввести предложение,
-считывает введенную строку,
-предлагает пользователю ввести символ,
-считывает введенный символ,
-добавляет символ пользователя после каждого пробела во введенной ранее строке
-выводит результат
#include <iostream>
int main() {
std::string str;
char n;
std::cout << "Input your string: ";
getline(std::cin, str);
std::cin.clear();
std::cout << "Input your character: ";
std::cin >> n;
for (int i = 0; i < str.size(); ++i) {
if (str[i] == ' ')
str.insert(i + 1, 1, n);
}
std::cout << str << "\n";
}