В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу на С++ определения площади пятиугольника с заданными координатами его вершин (x1, y1), (x2, y2), (х3у3), (х4.y4), (х5,y5) как сумму площадей трех треугольников. Площадь треугольника, определенную по координатам вершин, рассчитать с функции.

Показать ответ
Ответ:
meshka123
meshka123
26.03.2022 04:03

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   // problem 1 //

   ll x;

   cin >> x;

   if(x > 0)

       x *= 5;

   else

       x -= 10;

   cout << x << "\n\n";

   // problem 1 //

   // problem 2 //

   ll a[3];

   for(ll i = 0; i < 3; i++)

       cin >> a[i];

   sort(a,a+3);

   cout << a[0] + a[1] << "\n\n";

   // problem 2 //

   // problem 3 //

   ll y;

   cin >> y;

   if(y > 0)

       y++;

   else

       y -= 2;

   cout << y << "\n\n";

   // problem 3 //

   // problem 4 //

   ll b[3];

   for(ll i = 0; i < 3; i++)

       cin >> b[i];

   sort(b,b+3);

   cout << b[2] + b[1];

   //problem 4 //

}

0,0(0 оценок)
Ответ:
dontgiveupDGU
dontgiveupDGU
09.07.2021 23:00

Цифры бывают разные: самыми распространёнными являются арабские цифры, представляемые знаками от нуля (0) до девяти (9); менее распространены римские цифры, их можно встретить на циферблате часов или в обозначении века (XIX век).

Поскольку чисел гораздо больше чем цифр, то для записи числа обычно используется набор (комбинация) цифр. Только для небольшого количества чисел — для самых малых по величине целых чисел — бывает достаточно одной цифры. Существует много записи чисел с цифр, называемых системой счисления. Величина числа может зависеть от порядка цифр в записи, а может и не зависеть. Это свойство определяется системой счисления и служит основанием для простейшей классификации таких систем, что позволяет все системы счисления разделить на четыре класса (группы):

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота