В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
алина3798
алина3798
01.08.2021 01:39 •  Информатика

Написать программу на с# Зал Большого театра столь велик, что артистам при выступлении необходимо иметь радиомикрофоны.

В начале и конце спектакля все артисты находятся за кулисами. Артисты выходят на сцену и покидают сцену через правую или левую кулису, при этом артист берет с собой один микрофон. Уйдя со сцены, артист оставляет микрофон за той кулисой, через которую он ушел.

Имеется режиссерский план, в котором для каждого артиста указано его прихода и ухода со сцены, а также то, через какие кулисы он входит и выходит.

Определите, какое наименьшее число микрофонов необходимо приготовить режиссеру за каждой кулисой до начала спектакля.

Формат входных данных
Первая строка входный данных содержит натуральное число n, 1<=n<10000. Далее идет n строк – инструкции для артистов. Каждая строка состоит из двух чисел и двух букв. Первое число – время выхода артиста от начала спектакля в секундах, второе число – время ухода артиста со сцены. Потом идет одна из двух букв "l" или "r" в зависимости от того, через какую кулису (левую или правую) приходит артист и еще одна буква, указывающая через какую кулису уходит артист. Например, строка "300 500 l r" означает, что актер выходит на сцену в момент времении 300 через левую кулису и уходит со сцены в момент 500 через правую кулису.

Времена приходов и уходов – целые неотрицательные числа, не превосходящие 10000. Строки во входном файле могут идти в произвольном порядке, не обязательно упорядоченные по времени. Если в один и тот же момент один артист уходит за кулису, а другой выходит из-за этой же кулисы, то он может передать ему микрофон в этот момент.

Формат выходных данных
Программа должна вывести два числа: минимальное количество микрофонов, которое должно быть в начале спектакля за левой и за правой кулисами.

Пример
Входные данные:
3
0 100 l r
50 150 l l
100 200 r l
Выходные данные
2 0

Показать ответ
Ответ:
ArtMaster455
ArtMaster455
11.02.2021 18:59
Немного теории в приложении, чтоб не надо было обьяснять ответы

1. В зависимости от изображения чисел системы счисления делятся на:
б. Арабские и римские;

2. Двоичная система счисления имеет основание:
б. 2;

3. Для представления чисел в шестнадцатеричной системе счисления используются:
с. цифры 0-9 и буквы A-F.

4. В какой системе счисления может быть записано число 402?
с. в пятеричной
Есть цифра 4 которой нет в 4ричной и менее

5. Чему равно число DXXVI в десятичной системе счисления?
а. 526;

6. Запись вида 352:
с. Отсутствует в двоичной системе счисления;

7. Какие цифры используются в шестеричной системе счисления?
а. 0,1,2,5;
От 0 до 5

8. какое минимальное основание должна иметь система счисления, если в ней можно записать числа: 401, 122, 232, 111;
а. 5;

9. Какое число записано некорректно?
с. 1212 в двоичной;

10. система счисления-это...?
 символический метод записи чисел

11. Что такое основание системы счисления?
Некое положительное число   1 которое определяет шаг разрядности

12. Позиционной системой счисления называют...
Система счисления где позиция имеет значение

13. Какое минимальное основание может иметь система счисления, если в ней записано число 235?
6

14. Запишите число 254 с римских цифр
CCLIV

15. Чему равно число XCII в десятичной системе счисления?
92

16. Запишите значения цифр A и E в 16-ричной системе счисления:...
А=10 Е=14

17. Переведите числа в десятичную систему счисления:
а. 1011011 ( в 2-ой системой счисления) = 91
б. 3421( в 5-ой системе счисления) = 486

18. Выполните действия:
а) 11011110(в 2-ой системе счисления)
 + 11010010(в 2-ой системе счисления);
 =110110000
в) 87АС(в 16-ричной системе счисления)
 - 2D6F(в 16-ричной системе счисления);
 = 5A3D
б) 20119(в троичной системе счисления)-  1012(в троичной системе счисления); - тут опечатка
г) 1101011 ( в двоичной системе счисления) * 1101 ( в двоичной системе счисления) = 10101101111

19. Переведите число 433 (в десятичной системе счисления) в двоичную, восьмеричную, шестнадцатеричную системы счисления:
110110001_2
661_8
1B1_16

20. вычислите сумму чисел 10(в 2-ой) + 10 (в 8-ой) + 10 (в 10-ой) + 10 (в 16-ой). Представить результат в двоичной системе счисления
2 + 8 + 10 + 16 = 26_10 = 1000110_2

21. В какой системе счисления будет верным равенство 4+4= 10 ?...
8

22. В какой системе счисления: а) 144(в 10-ой) записывается как 100;
144 = 12*12 значит основание 12
б) 98( в 10-ой) записывается как 200;
98 = 2*7*7 значит 7ричная
в) 48(в 10-ой) записывается как 300.
48 = 3*4*4 значит 4ричная
0,0(0 оценок)
Ответ:
maiagolubeva5
maiagolubeva5
11.02.2021 18:59
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

Нулевой шаг: создание типизированного файла нужной структуры

begin
  var f:file of real;
  Assign(f,'MyReal.bin'); Rewrite(f);
  loop 2 do begin
    SeqRandomInteger(10,1,100).Select(t->t/10).ForEach(t->Write(f,t));
    SeqRandomInteger(10,-100,-1).Select(t->t/10).ForEach(t->Write(f,t));
    end;
  f.Seek(0); // начало файла
  var b:real;
  while not Eof(f) do begin Read(f,b); Print(b) end;
  Println;
  f.Close
end.

Пример:
9.7 1 4.1 8.3 5.6 9.3 2.2 9.3 5.8 8.8 -8.8 -7.7 -1.4 -5.2 -7.2 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 4.5 10 4.5 6.1 0.7 -8 -0.8 -3.3 -9.5 -7.9 -0.9 -7.4 -9.4 -1.8 -4.6

Собственно, программа

begin
  var f1,f2:file of real;
  Assign(f1,'MyReal.bin'); Reset(f1);
  if f1.FileSize mod 20<>0 then begin
    Writeln('Количество компонент во входном файле не кратно 20');
    Exit
    end;
  Assign(f2,'MyReal2.bin'); Rewrite(f2);
  var buf:=new real[5];
  var b:real;
  while not Eof(f1) do begin
    // переписываем пять положительных
    loop 5 do begin Read(f1,b); Write(f2,b) end;
    // считываем пять положительных в буфер
    for var i:=0 to 4 do Read(f1,buf[i]);
    // переписываем пять отрицательных
    loop 5 do begin Read(f1,b); Write(f2,b) end;
    // пишем пять положительных из буфера
    foreach var t in buf do Write(f2,t);
    // переписываем пять отрицательных
    loop 5 do begin Read(f1,b); Write(f2,b) end
    end;
  f1.Close;
  // контрольное чтение 
  f2.Seek(0); // к началу 
  while not Eof(f2) do begin Read(f2,b); Print(b) end;
  Writeln; 
  f2.Close
end.

Пример
9.7 1 4.1 8.3 5.6 -8.8 -7.7 -1.4 -5.2 -7.2 9.3 2.2 9.3 5.8 8.8 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 -8 -0.8 -3.3 -9.5 -7.9 4.5 10 4.5 6.1 0.7 -0.9 -7.4 -9.4 -1.8 -4.6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота