В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gulua1
gulua1
05.11.2022 19:29 •  Информатика

Написать программу на С++ Заполнить массив из 10 элементов случайными числами в интервале -10 10 и выполнить инверсию отдельно для 1-ой и 2-ой половин массива

Показать ответ
Ответ:
dashaskulova
dashaskulova
12.06.2021 06:42

var

       a: array [1..30] of Word;

       i, c, sum: Word;

       

begin

       Randomize;

       

       for i := 1 to 30 do

               a[i] := Random (76);

       

       for i := 1 to 30 do

               Write (a[i], ' ');

       

       WriteLn;

       

       for i := 1 to 30 do

               if (a[i] >= 10) and (a[i] <= 35) then begin

                       Inc (c);

                       sum := sum + a[i];

                       Write (a[i], ' ')

               end;

       

       WriteLn;

       WriteLn ('Кол-во чисел из диапазона [10; 35]: ', c);

       Write ('Сумма чисел из диапазона [10; 35]: ', sum);

end.        

0,0(0 оценок)
Ответ:
EdwardLab
EdwardLab
07.05.2022 20:06

Проприоцепция — «ощущение тела»

Этот орган чувств распределён по всему телу подобно осязанию и находится в мышцах и быстропроводящих нервных волокнах. Он позволяет определить положение частей тела относительно друг друга. Чтобы ощутить его действие, попробуйте, закрыв глаза, поднять одну коленку над другой и немного ею подвигать. Благодаря проприоцепции вы всегда будете знать, какая из двух коленок выше, на каком они расстоянии друг от друга и многое другое.

Ноцицепция — болевой орган чувств

Служит в основном для формирования в человеке понимания, что безопасно, а что нет. Например, когда ребёнок подносит руку к пламени, идёт два процесса: рука рефлекторно отдёргивается, а в мозг передаётся ощущение боли. Ноцицепция как раз отвечает за это ощущение. Если бы в теле не было рецепторов боли, человек получал бы травмы в разы чаще — он бы просто не знал, что для него опасно, а что нет!

Эквибриоцепция — чувство равновесия

Наверное, самый известный из неизвестных органов чувств. Вестибулярные каналы находятся во внутреннем ухе и нам определить положение тела в пространстве. При этом неважно, может ли человек видеть, слышать или осязать — с органов равновесия он всегда понимает, как через него проходит, говоря физическим языком, вектор силы тяжести.

Термоцепция — теплоощущение

Здесь всё просто — терморецепторы расположены по всей коже и могут давать сигналы о присутствии либо отсутствии на ней высоких температур. Иногда эту систему рецепторов включают в осязание, но её важность для человека избежать ожогов, перегрева или обморожения) позволяет выделить термоцепцию в отдельный орган чувств.

Ощущение вибрации

Человек может распознавать вибрации частотой от 1 до 10 000 Гц. Амплитуда колебаний различается с точностью до 5 мкм. Основные отделы чувствительности этого органа находятся в ступнях и кистях. Кстати, слух — это, фактически, составляющая вибрационной чувствительности, ведь мы можем определять звуки с колебаний барабанной перепонки.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота