В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
холера663
холера663
12.07.2021 04:35 •  Информатика

написать программу на си шарп или паскале
Для строительства требуются доски в количестве не менее а куб.м. Имеются доски 2-х видов. При обработке i-го вида доски получается рi ед. отходов. Цена доски i-го вида - сi , объем - vi Денежный фонд ограничен b. В каком количестве следует закупить доски каждого вида, чтобы отход был минимален?

Показать ответ
Ответ:
omim
omim
08.02.2020 22:53

1.Распространёнными внешними носителями информации являются компакт-диски, жёсткие диски и флеш-накопители. Компакт-диски предназначены либо только для чтения информации, либо для чтения и записи, однократной или многократной. Жёсткие диски и флешки предназначены для чтения и многократной записи файлов.

2.Внешние носители информации

ФлешкиUSB-флешки

Внешние жесткие диски

HDD боксы

3.Чтобы иметь возможность прочитать диск Blu-ray на другом компьютере, он должен быть оснащен устройством записи Blu-ray дисков. Чтобы прочитать DVD-диск на другом компьютере, он должен быть оснащен DVD или Blu-ray-дисков. Компакт-диски можно использовать с дисководами для DVD- и компакт-дисков и с большинством (но не со всеми) Blu-ray-дисководов.

4. DVD+RDL DVD-R DL DVD-RAM DVD+RW DVD-RW DVD+R DVD-R DVD-ROM CD-RW CD-RC D-ROM

5.Записать и перезаписать.

И CD, и DVD-диски бывают такие, на которые можно записать только один раз (CD-R, DVD-R), и такие, которые можно перезаписывать, то есть, стереть и заново записать (CD-RW, DVD-RW)

Объяснение:

6 не знаю прости наверно так подойдёт

0,0(0 оценок)
Ответ:
danyaсс
danyaсс
19.08.2022 14:12

Описание алгоритма:

Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы(так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны):

1) Заканчиваются на 0.

2) Ровно на одну единицу

3) Ровно на две единицы.

Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т.к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для N=1 и N=2 также работает правильно.

Программа на Pascal:

var num00,num01,num11,mem00:integer;

   n,i:byte;

begin

readln(n);

 num00:=1;

 for i:=1 to n do begin

   mem00:=num11;

   num11:=num01;

   num01:=num00;

   num00:=num01+num11+mem00;

 end;

writeln(num11+num01+num00);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота