В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
saraikinacaterina
saraikinacaterina
18.10.2021 03:14 •  Информатика

Написать программу на создать файл а4, состоящий из 28 целых чисел. найти среднее арифметическое всех чисел.

Показать ответ
Ответ:
Кристина1333
Кристина1333
01.10.2020 22:48
Program abc;
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
  x, y: longint;
  i: byte;
begin
  y := 0;

  assign(f, 'a4');
  reset(f);

  for i := 1 to 28 do
  begin
    read(f, x);
    y := y + x;
  end;

  writeln(y / 28);
  close(f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота