В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Dariasolne4naya
Dariasolne4naya
02.01.2022 15:48 •  Информатика

Написать программу: на вход программы поступает неизвестное количество чисел целых, ввод заканчивается нулём. найти максимальное из введённых чётных чисел. python.

Показать ответ
Ответ:
Kotic777
Kotic777
07.10.2020 20:15

list_number = []    # Создали список, сюда заносим числа.

number = int(input())   # Вводим число

while number != 0:    # Проверяем на равенство число нулю

   list_number.append(number)    # Добавляем число в список

   number = int(input())   # Вводим след.число

if list_number: # Если список не пуст

   # Фильтруем список(возвращаем список только с четными числами) и выбираем максимальное

   result_number = max(list(filter(lambda x: x % 2 == 0, list_number)))    

   print("Result: {0}".format(result_number))  # Выводим результат

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота