В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
yyyoooppp
yyyoooppp
07.04.2020 12:37 •  Информатика

Написать программу на ЯП (язык программирования) Pascal, в которой бы объявлялся массив чисел типа byte и размерности 3x3. Программа должна вывести на экран все элементы массива в виде последовательности или матрицы, при этом к каждому элементу массива должна быть применена заданная математическая функция 10x.

Показать ответ
Ответ:
lag228
lag228
04.06.2020 00:31
1)
#include <iostream>

using namespace std;

int main() {
  cout << "Сколько Вам лет?" << endl;
  int age;
  string s;
  cin >> age >> s;
}
2)
#include <iostream>

using namespace std;

int main() {
  cout << "Сколько Вам лет?" << endl;
  int age;
  cin >> age;
  if(age < 0) cout << "wrong" << endl;
  else if(age >= 18) cout << "yes" << endl;
  else cout << "no" << endl;
}

3)
#include <iostream>

using namespace std;

int main() {
 int a;
 cin >> a
 if(a%2 == 0) cout << "четное" << endl;
 else cout << "нечетное" << endl;
}

4)
#include <iostream>

using namespace std;

int main() {
 int a,b,c;
 string s = "";
 cin >> a >> b >> c;
 if(a == b && a == c) cout << "равносторонний" << endl;
 else {
    if (a==b || a == c || b == c) s += "равнобедренный";
    if( a*a == (b*b+c*c) || b*b == (a*a+c*c) || c*c == (a*a+b*b))
           s+= "прямоугольный";
    if(s == '') cout << "обычный" << endl;
    else cout << s << endl;
  }
}
 
 
0,0(0 оценок)
Ответ:
Никита256366
Никита256366
06.12.2022 07:49

Давай сравним все 4 числа между собой, найдём максимальное и вычтем из него N.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a, b, c, d, n;

   cin >> a >> b >> c >> d >> n;

   if (a > b && a > c && a > d)

       a -= n;

   else if (b > a && b > c && b > d)

       b -= n;

   else if (c > a && c > b && c > d)

       c -= n;

   else d -= n;

   cout << a << " " << b << " " << c << " " << d << endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота