В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
85kurganova85
85kurganova85
22.11.2022 08:08 •  Информатика

Написать программу на языке C++ (c#) которая вводит целое чило n и массив из n целых чисел и определяет есть ли в массиве число 30.

Показать ответ
Ответ:
123451175
123451175
13.10.2020 14:49

C#

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n;

           bool b = false;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           int[] A = new int[n];

           Console.WriteLine("Введите массив: ");

           for (int i = 0; i < n; i++)

           {

               A[i] = Convert.ToInt32(Console.ReadLine());

               if (A[i] == 30) b = true;

           }

           Console.WriteLine("В массиве "+(b ? "есть" : "нет")+" числ"+ (b ? "о" : "а") + " 30");

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота