В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ismoilova97
ismoilova97
01.11.2020 18:50 •  Информатика

Написать программу на языке C++: Даны катеты двух прямоугольных треугольников a1;b1 и a2;b2. У какого из двух треугольников больше периметр (гипотенуза c^2=a^2+b^2).


Написать программу на языке C++: Даны катеты двух прямоугольных треугольников a1;b1 и a2;b2. У како

Показать ответ
Ответ:
arinkaapelsink
arinkaapelsink
15.10.2020 14:32

Объяснение:

#include <bits/stdc++.h>

using namespace std;

int bigger_P(int a, int b, int c, int d)

{

   if(a+b+sqrt(pow(a, 2)+pow(b, 2))>c+d+sqrt(pow(c, 2)+pow(d, 2)))return 1;

   if(a+b+sqrt(pow(a, 2)+pow(b, 2))<c+d+sqrt(pow(c, 2)+pow(d, 2)))return 0;

   return -1;

}

int main()

{

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   int a, b, c, d;

   cin>>a>>b>>c>>d;

   if(bigger_P(a, b, c, d)==1)cout<<"First perimetr is bigger.";

   if(bigger_P(a, b, c, d)==0)cout<<"Second perimetr is bigger.";

   if(bigger_P(a, b, c, d)==-1)cout<<"They are equal.";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота