В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
M10041999
M10041999
26.10.2021 05:57 •  Информатика

Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x< -10 и b неравно 0; (x/(x- при x> 0 и b=0; -(|x|*x^2)/c в остальных случаях}

Показать ответ
Ответ:
isaevaa24
isaevaa24
16.08.2020 23:51

#include <iostream>

#include <iomanip>

#include <cmath>


int main()

{

float

 a, b, c, x,

 f = 0.0f;

std::cout << "Введите значения переменных A, B, C, X: ";

std::cin >> a >> b >> c >> x;


if(x < - 10 && b != 0)

 f = -a * pow(x, 2) + pow(b, 3);

else if(x > 0 && b == 0)

 f = x / ((x-c) - a);

else f = -(abs(x) * pow(x, 2)) / c;


std::cout << "Значение переменной f = " << std::setprecision(3) << f << std::endl;

}

g++ compiler

В общем, я не знал, как сохранить блок-схему в фотку, поэтому держи так. Просто срисуй, если нужно. Уж извиняй :)


Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x<
Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x<
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота