В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
arekhvanova
arekhvanova
12.05.2020 01:25 •  Информатика

Написать программу на языке c++ с процедур
напишите процедуру, которая выводит на экран запись переданного ей числа в
римской системе счисления.
введите натуральное число:
mmxiii
буду

Показать ответ
Ответ:
шкуровоз
шкуровоз
11.10.2020 04:13

Дак это уже было написано тысячу раз...

static void Rom(int N) {

string out="";

string rom[] = { "M", "CM", "D", "CD", "C", "XC", "L", "XL", "X", "IX", "V", "IV", "I" };

int dec[] = { 1000, 900, 500, 400, 100, 90, 50, 40, 10, 9, 5, 4, 1 };

while (N > 0) {

   int i = 0;

   while (N < dec[i]) i++;

   out+=rom[i];

   N -= dec[i];

}

cout << out;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота