В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
КсюшаЛор
КсюшаЛор
04.05.2020 12:09 •  Информатика

Написать программу на языке c++ вам даётся 3 числа. требуется установить, возможно ли составить из них пифагоров треугольник. входные данные 3 целых числа, по модулю не превышающие 2 000 000 000. выходные данные если из чисел возможно составить пифагоров треугольник выведите "yes", иначе "no".

Показать ответ
Ответ:
xeniaverner
xeniaverner
05.10.2020 20:58
#include <iostream>
using namespace std;

int main() {
int a, b, c;
cout << "a, b, c: ";
cin >> a >> b >> c;
if ((a*a+b*b==c*c)||(a*a+c*c==b*b)||(b*b+c*c==a*a))
  cout << "YES";
else cout << "NO";
return 0;
}

Пример:
a, b, c: 1960509751 395427000 1999990249
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота