Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
АннаЛютинго
16.02.2020 04:22 •
Информатика
Написать программу на языке pascal для решения следующей : дан массив 4x4 из целых чисел. вычислить в массиве количество элементов равных пяти, имеющих чётные индексы строки. ввод массива, вычисление количества оформить в виде подпрограмм.
Показать ответ
Ответ:
poli148
07.10.2020 14:58
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
function MatRead:array[,] of integer;
begin
Writeln('Вводите элементы через пробел построчно');
Result:=ReadMatrInteger(4,4)
end;
function PartCount(a:array[,] of integer):=
a.ElementsWithIndexes.Where(t->(t[0]=5) and t[1].IsOdd).Count;
begin
var a:=MatRead;
Writeln('*** Исходный массив ***');
a.Println(6); Writeln(6*a.ColCount*'-');
Writeln('Искомых элементов: ',PartCount(a))
end.
Пример
Вводите элементы через пробел построчно
34 12 21 5 0 3 12 5 -6 18 5 16 5 -15 16 7
*** Исходный массив ***
34 12 21 5
0 3 12 5
-6 18 5 16
5 -15 16 7
Искомых элементов: 2
0,0
(0 оценок)
Популярные вопросы: Информатика
ulyanooo
08.12.2021 17:00
Решите все,пропустила месяц учебы и сразу проверочная(лг...
люблютебя4
31.10.2022 07:25
Минформатикой, ! и обязательно с решением, во вложении...
ника2144
26.11.2022 06:31
Нужен простенький код для сайта на html с 4 страницами ...
perminovdima20
09.04.2020 13:22
Сфункций mod, div, сформировать число, представляющее собой реверсную (обратную в порядке следования разрядов) запись заданного четырёхразрядного числа. например,...
kif1305
16.11.2021 11:07
Какой из этапов при разработке программы решения поставленной задачи является наиболее важным?постановки проблемытестирование программыИ почему?...
Vostafi
25.01.2023 02:30
1. Какие требования к инфографике вы можете предложить? Обоснуйте эти требования. 2. Выполните задания по уровням. Уровень А. Найдите в сети Интернет примеры на...
evrolokki
18.09.2020 22:45
Составить программу нахождения площади прямоугольника,если известны его стороны...
sofiiishtepa
19.09.2022 19:31
Переведите число 285 из десятичной системы счисления в двоичную, восьмеричную, шестнадцатеричную....
tvoibati00
04.02.2021 16:35
Цикл ПОКА условие последовательность команд КОНЕЦ ПОКА выполняется, пока условие истинно. Дана программа для редактора: НАЧАЛО ПОКА нашлось (01) ИЛИ нашлось (02)...
Ариэль1606
16.09.2022 10:01
У меня планшет HUAWEI MEDIAPAD T5 и есть карта памяти на 32 гб, и не получается перенести игры на карту памяти, хотя на телефоне могу...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
function MatRead:array[,] of integer;
begin
Writeln('Вводите элементы через пробел построчно');
Result:=ReadMatrInteger(4,4)
end;
function PartCount(a:array[,] of integer):=
a.ElementsWithIndexes.Where(t->(t[0]=5) and t[1].IsOdd).Count;
begin
var a:=MatRead;
Writeln('*** Исходный массив ***');
a.Println(6); Writeln(6*a.ColCount*'-');
Writeln('Искомых элементов: ',PartCount(a))
end.
Пример
Вводите элементы через пробел построчно
34 12 21 5 0 3 12 5 -6 18 5 16 5 -15 16 7
*** Исходный массив ***
34 12 21 5
0 3 12 5
-6 18 5 16
5 -15 16 7
Искомых элементов: 2