В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Digger2001
Digger2001
01.04.2023 12:39 •  Информатика

Написать программу на языке pascal. найти значение выражения для заданного x. 1.1. 2x+5; 1.2. 3x^2+1x+7; 1.3. 3x+7; 1.4. 2x^2+7+10 знак ^ обозначает степень числа, а в паскале записывается как sqr(x), где x переменная.

Показать ответ
Ответ:
ариариииирпа
ариариииирпа
17.07.2020 21:52
Var x:integer;
begin
x:= ;//Сюда ввести значение.
  writeln(2*x+5);
  writeln(3*Sqr(x)+1*x+7);
  writeln(3*x+7);
  writeln(2*sqr(x)+7+10);
end.

С вводом X:

var x:integer;
begin
 writeln('Введите x: ');
 readln(x);
  writeln(2*x+5);
  writeln(3*Sqr(x)+1*x+7);
  writeln(3*x+7);
  writeln(2*sqr(x)+7+10);
end.
0,0(0 оценок)
Ответ:
Нznm
Нznm
17.07.2020 21:52
Var
x,i,a1,a2,a3,a4:integer;
Begin
readln(x);
a1:=2*x+5;
a2:=3*sqr(x)+x+7;
a3:=3*x+7;
a4:=2*sqr(x)+7+10;
writeln(a1);
writeln(a2);
writeln(a3);
writeln(a4);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота