В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
daschkavolf
daschkavolf
08.03.2022 09:45 •  Информатика

Написать программу на языке pascal: : вводятся целые числа до первого числа, которое меньше двух. определить, сколько простых чисел было введено. описание переменных: q - счетчик простых чисел; n - очередное введенное число. алгоритм решения : пока введенное число больше 1, проверять его на простоту по следующему алгоритму: если число делится на любой делитель от 2 до половины от себя, то оно не простое. если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.

Показать ответ
Ответ:
shahnozat02
shahnozat02
06.07.2020 16:00
Var q,n,i,k,h:integer;
begin
readln(n);
h:=1;
while n>1 do
  begin
  k:=n div 2;
  for i:=2 to k do
    if n mod i=0 then h:=0;
  q:=q+h;
  h:=1;
  readln(n);
  end;
writeln('Простых чисел: ',q)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота