Написать программу на языке паскаль.
Циклический алгоритм с предусловием задан в виде словесного описания. Заданы начальные значения переменных:
x:=1; y:=5;
Начало цикла. Пока y>x выполнить:
y: = y – x;
k=k+1;
конец цикла;
Определить количество циклов k и значения переменной y после выхода из цикла.
Две переменные k и y, вывести на экран один раз
var
x, y, k: integer;
begin
x := 1;
y := 5;
k := 0;
while y > x do
begin
y := y - x;
k := k + 1;
end;
Writeln('Количество циклов: ', k);
Writeln('Значение переменной Y: ', y);
end.
Тестовое решение:
Количество циклов: 4
Значение переменной Y: 1