Написать программу на языке Паскаль.
Дана последовательность чисел.Требуется упорядочить их по убыванию.Для этого в массиве ,начиная с первого, выбирается наибольший элемент и ставится на первое место,а первый -на место наибольшего.Затем, начиная со второго,эта процедура повторяется.
const
nmax=100;
var
n,i,j,nn,nz,np,t:integer;
a,an,az,ap:array[1..nmax] of integer;
begin
// формируем массив и выводим его
Write('Количество элементов в массиве: '); Read(n);
for i:=1 to n do begin
a[i]:=Random(11)-5;
Write(a[i],' ')
end;
Writeln;
// разбиваем массив на три подмассива
nn:=0; nz:=0; np:=0;
for i:=1 to n do
if a[i]<0 then begin nn:=nn+1; an[nn]:=a[i] end
else
if a[i]=0 then begin nz:=nz+1; az[nz]:=a[i] end
else begin np:=np+1; ap[np]:=a[i] end;
// сортируем массив с отрицательными элементами по убыванию
for i:=1 to nn-1 do
for j:=1 to nn-1 do
if an[j]<an[j+1] then
begin t:=an[j]; an[j]:=an[j+1]; an[j+1]:=t end;
// сортируем массив с положительными элементами по возрастанию
for i:=1 to np-1 do
for j:=1 to np-1 do
if ap[j]>ap[j+1] then
begin t:=ap[j]; ap[j]:=ap[j+1]; ap[j+1]:=t end;
// формируем новое содержимое массива a
i:=0;
for j:=1 to nz do begin i:=i+1; a[i]:=az[j] end;
for j:=1 to np do begin i:=i+1; a[i]:=ap[j] end;
for j:=1 to nn do begin i:=i+1; a[i]:=an[j] end;
// вывод результата
for i:=1 to n do Write(a[i],' ');
Writeln
end.
Тестовое решение:
Количество элементов в массиве: 15
1 2 5 0 -5 -3 0 0 1 -4 3 -2 -2 0 -5
0 0 0 0 1 1 2 3 5 -2 -2 -3 -4 -5 -5
begin
var n:=ReadInteger('Количество элементов в массиве: ');
var a:=ArrRandom(n,-50,50);
a.Println(',');
Writeln('Четные элементы: ');
var i:=1;
while i<n do begin Write(a[i],' '); Inc(i,2) end;
Writeln;
Writeln('Нечетные элементы: ');
i:=0;
while i<n-1 do begin Write(a[i],' '); Inc(i,2) end;
Writeln
end.
Тестовое решение:
Количество элементов в массиве: 10
15,-18,-29,-25,46,21,-8,-17,-9,15
Четные элементы:
-18 -25 21 -17 15
Нечетные элементы:
15 -29 46 -8 -9