В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Настя456456
Настя456456
28.10.2022 23:52 •  Информатика

Написать программу на языке паскаль дано: а,b,с найти: s s=sqrt(p(p-a)(p-b)(p-c)) где р=(а+b+c)/2

Показать ответ
Ответ:
KseniaДьявол
KseniaДьявол
06.08.2020 23:20
Var a,b,c,s:real;

procedure Pl(var a,b,c,s:real);
var p:real;
begin;
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(s);
end;

begin;
readln(a);
readln(b);
readln(c);
if (a>=(b+c)) or (b>=(a+c)) or (c>=(a+b)) then
begin;
writeln('error');
exit;
end;
Pl(a,b,c,s);
end.
0,0(0 оценок)
Ответ:
KekCheburashka
KekCheburashka
06.08.2020 23:20
Var a,b,c,s:integer;
function f(a1,b1,c1:real):real;
var p:real;
begin
p:=(a+b+c)/2;
f:=sqrt(p*(p-a)*(p-b)*(b-c)); end;
BEGIN
readln(a,b,c);
writeln('S=',f(a,b,c):4:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота