В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу на языке Паскаль используя цикл «пока»: Дано число Х = 4. Нужно выводить на экран цифры, кратные 4 пока Х< 100

Показать ответ
Ответ:
mashaleonteva2
mashaleonteva2
03.02.2022 10:38
Код#include <iostream>#include <string>#include <functional>std::string switch_first_and_last(std::string N) {    auto L = N.size() - 1;    return N[L] + N.substr(1, L - 1) + N[0];}bool take_correct_number(int &number, const std::function<bool(int)>& Q) {    do {        std::cin >> number;        if (!Q(number)) {            std::cout << "Try again." << std::endl;            continue;        }        break;    } while (true);    return true;}int main() {    int number;    take_correct_number(number, [](int x){return x > 9;});    std::cout << switch_first_and_last(std::to_string(number)) << std::endl;}
Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результа
0,0(0 оценок)
Ответ:
jhgvbbbg
jhgvbbbg
27.10.2020 20:54

в MSO Word уже есть различные предустановленные стили и можно выбрать на свой вкус

Если вы хотите сделать свой стиль, то отталкиваться надо от тематики документа (доклад, любовное письмо, открытка, резюме, стихи), так же где будет использоваться (электронный вид, распечатка, конвертация в другие форматы, конвертация в интернет страницу). Если вы хотите передавать документ в электронном виде, то старайтесь использовать стандартные шрифты, так как у ваших друзей может не оказаться экзотических шрифтов, что негативно повлияет на форматирование документа

Шрифты это дело вкуса вообще, но есть некоторые стандарты для некоторых документов (дипломы,  рефераты...), например Times New Roman, Arial, Corier New. Сейчас продвигаются более приятные для глаз стандарты Cambria, Calibri, Consolas

Заголовки - должны сильно отличаться от основного текста, потому выделяются большим размером кегля, цветом, курсивом, жирностью, другим шрифтом, выравниванием и тд. Так же можно использовать и всякие другие украшательства такие как цвет фона, графические элементы, тени, рисованные шрифты и  пр

основной текст - обычный текст, часто без курсивов и жирности, нейтрального цвета (обычно черный), приятный для чтения, но не бросающийся в глаза

выделенный текст - такой же как основной текст, но с добавкой одного или нескольких элементов: жирность, курсив, цвет, чуть больше или меньше размер, подчеркивание, заглавные буквы, фон, тень

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота