В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
znj93294znj93294
znj93294znj93294
08.08.2022 10:40 •  Информатика

Написать программу на языке Паскаль, которая получает на вход (вы вводите с клавиатуры) трехзначное число, а затем однозначное, программа проверяет, есть ли однозначное число в трехзначном в виде одной из его цифр, программа должна вывести ответ на экран "да есть" или "такой цифры нет"
Выполняя это задание назовите любую из переменных своим именем.

Показать ответ
Ответ:
valiullina12601
valiullina12601
12.10.2020 21:41

PascalABC.NET

begin

 var Глебов := ReadInteger('Введи трехзначное положительное число:');

 var Цифра := ReadInteger('Введи цифру от 0 до 9:');

 while Глебов > 0 do

 begin

   if Цифра = Глебов mod 10 then

   begin

     Print('да, есть');

     exit

   end;

   Глебов := Глебов div 10

 end;

 Print('такой цифры нет')

end.

0,0(0 оценок)
Ответ:
gfdehk
gfdehk
12.10.2020 21:41

var trehznachnoe,odnoznachnoe: integer;

begin

write('Введите трехзначное число, а затем однозначное: ');

readln(trehznachnoe,odnoznachnoe);

if (trehznachnoe mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 10) mod 10 = odnoznachnoe) then

writeln('да есть')

else if ((trehznachnoe div 100) mod 10 = odnoznachnoe) then

writeln('да есть')

else writeln('такой цифры нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота