Написать программу на языке паскаль: на место положительных элементов массива (a1, ) записать единицы и сосчитать их количество. для отрицательных элементов массива определить их сумму. исходные данные: n=12 a= [-8, 10, 11, -30, 21, 22, -5, 10, -10, -12, 1, 5]
var a:array[1..100] of integer;
k,sum,n,i:integer;
Begin randomize;
k:=0;
sum:=0;
writeln('Введите размерность массива',n);
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
begin if a[i]>0 then
begin a[i]:=1;
k:=k+1;
end;
write(' ',a[i]);
if a[i]<0 then
begin sum:=sum+a[i];
end;
end;
writeln(' sum=',sum,' k=',k);
readln;
End.