В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anyyy001
anyyy001
30.03.2021 13:35 •  Информатика

Написать программу на языке паскаль. определить и напечатать количество ненулевых элементов в каждой колонке заданной матрици.скласты и напечатать матрицу, каждый элемент которой исчисляется как разница значений соответствующего элемента заданной матрицы и минимального элемента строки

Показать ответ
Ответ:
mariyakarimova2
mariyakarimova2
21.01.2022 18:38
1. Переведем 271 из 8-ой в 10-ую = 2*8^2 + 7*8^1 + 1 = 128 + 56 + 1 = 185.
Переведем 11110100 из 2-ой в 10-ую = 2^7 + 2^6 + 2^5 + 2^4 + 2^2 = 128 + 64 + 32 + 16 + 4 = 244.
185 + 244 = 429. В 16: 429/16 = 26 (ост: 13 = D); 26 / 16 = 1 (ост 10 = A). 
ответ: 1AD. 

2. 19 из 10-ой переведём в 6-ую = 31. Также переведём 33 из 10-ой в 6-ую = 53.
Перечислим все наборы:
33 34 35 40 41 42 43 44 45 50 51 52 53. 
Считаем тройки и получаем их количество - 6. 

3. 49[10cc] = 100[x cc]. Распишем 100 и получим = 1*x^2 + 0*x^1 + 0*x^0 = x^2. => 49 = x^2; x = 7.
ответ: 7. 

4. Переведём число 30 из 10-ой в 4-ую СС и получим: 132. Нам надо найти числа, которые оканчиваются на 31. Значит все последующие разряды будут x. x31 < 132. Если x = 0, то будет следующее число 031, оно меньше 132 и значит подходит. Если x = 1, то будет число 131 и оно также подходит. Все последующие число не подходят, поэтому ответ только два числа. 

5. Долго делать это, чем смог
0,0(0 оценок)
Ответ:
Makaezhik02
Makaezhik02
21.01.2022 18:38
CLS
a:
INPUT n
IF n < 1 OR INT(n) <> n OR n > 1000 THEN GOTO a
DIM a(n)
h=30000
FOR i = 1 TO n
b:
INPUT a(n)
IF a(n) < 1 OR INT(a(n)) <> a(n) OR a(n) > 30000 THEN GOTO b
IF INT ((a(n) - 4 ) / 10) = ((a(n) - 4) / 10) AND a(n) < h THEN h = a(n)
NEXT i
PRINT h
END
или:
n - количество чисел
i - цикловая переменная
a  - натурально число
min  - минимальное число, оканчивающееся на 4
Язык програмирования: Паскаль
var
n,i,a,min: integer;
begin
readln(n);
min := 30001;
for i := 1 to n do
begin
readln(a);
if (a mod 10 = 4) and (a < min) then
min := a;
end;
writeln(min)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота