В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
creeperm477
creeperm477
03.03.2022 11:40 •  Информатика

Написать программу на языке паскаль
сформировать и вывести на экран массив из 15 элементов, элементы которого заданы датчиком случайных чисел на интервале [-50, 79] . найти произведение элементов этого массива.
ps: программу пишем по аналогии с примером на стр. 68

Показать ответ
Ответ:
irina895
irina895
10.10.2020 19:50

program n_1; //заголовок программы

const N=15; // блок описания используемых данных

var

i,p:integer;

a:array[1..n] of integer;

begin //программный блок

for i:=1 to n do

a[i]:=random(130)-50; //заполняем массив

for i:=1 to n do

p:=p*a[i]; //вычисляем произведение

writeln; //переходим на новую строчку

write(p); //выводим произведение

end. //завершаем программу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота