В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sofirzhk
sofirzhk
11.10.2021 12:43 •  Информатика

Написать программу на языке паскаль. Задача на нахождение скорости по течению

Показать ответ
Ответ:
Var
 x,a,b,c,max,min,mid:real;
begin
 readln(x);
 a:=sin(x);
 b:=cos(x);
 if a>0 then
  begin
   c:=ln(x);
   if (a>b) and (a>c) then max:=a else
   if (b>a) and (b>c) then max:=b else max:=c;
   if (a<b) and (a<c) then min:=a else
   if (b<a) and (b<c) then min:=b else min:=c;
   if (a>min) and (a<max) then mid:=a else
    if (b>min) and (b<max) then mid:=b else mid:=c;
   writeln(min,' ',mid,' ',max);
  end
 else
  if a>b then writeln(b,' ',a) else writeln(a,' ',b);
end.
0,0(0 оценок)
Ответ:
ladygum78
ladygum78
01.06.2023 14:21
Внешняя память - это память, предназначенная для длительного хранения программ и данных. Целостность содержимого ВЗУ не зависит от того, включен или выключен компьютер

Дисковод (накопитель) - устройство записи/считывания информации. Накопители имеют собственное имя – буква латинского алфавита, за которой следует двоеточие. Для подключения к компьютеру  одного или несколько дисководов и управления их работой нужен Дисковый контроллер

Носитель информации (носитель записи) – материальный объект хранить информацию. Информация записывается на носитель посредством изменения физических, химических и механических свойств запоминающей среды

По типу доступа к информации внешнюю память делят на два класса:

Устройства прямого (произвольного) доступа –  время обращения к информации не зависит от места её расположения на носителе;

Устройство последовательного доступа – такая зависимость существует

В состав внешней памяти входят:  1) накопители на жестких магнитных дисках (НЖМД);  2) накопители на гибких магнитных дисках (НГМД);  3) накопители на магнитооптических компакт дисках;  4) накопители на оптических дисках (CD-ROM);  5) накопители на магнитной ленте и др.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота