Написать программу на языке программирования Паскаль, используя операторы ветвления if, then, else. Ведется прием на работу на конкурсной основе. Условия приема требуют 20 лет трудового стажа и возраста не более 45 лет.Определить,будет ли человек принят на работу. Примечание: два условия записываются в виде (x<5) or (x>6), (x<5) and (x>6) - выберите нужную запись для условия, подставляя значения из задачи.
ответ:
объяснение:
используем формулу нахождения объема:
i = m x n * i
подсчитаем каждый сомножитель в формуле, стараясь числа к степеням двойки:
m x n:
160 * 160 = 20 * 2³ * 20 * 2³ = 400 * 26 =
= 25 * 24 * 26
нахождение глубины кодирования i:
256 = 28
т.е. 8 бит на пиксель (из формулы кол-во цветов = 2i)
находим объем:
i = 25 * 24 * 26 * 23 = 25 * 213 - всего бит на всё изображение
переводим в кбайты:
(25 * 213) / 213 = 25 кбайт
n=5;m=6;
var
a:array[1..n,1..m]of integer;
b:array[1..m]of longint;
k,i,j:integer;
p:longint;
begin
for i:=1 to n do
begin
writeln;
for j:=1 to m do
begin
a[i,j]:=random(20)-10;
write(a[i,j]:4);
end;
end;
writeln;
for j:=1 to m do
begin
p:=1;
for i:=1 to n do
if (a[i,j]mod 2=0)and(a[i,j]>0) then
p:=p*a[i,j];
if p<>1 then
begin
k:=k+1;
b[k]:=p;
end;
end;
for i:=1 to k do
write(b[i]:8);
end.