В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Uncleuncle1
Uncleuncle1
30.04.2020 04:54 •  Информатика

Написать программу на языке программирования Turbo Pascal и составить блок схему. нап">

Показать ответ
Ответ:
ВАНЯПУХОВ
ВАНЯПУХОВ
22.12.2022 13:46

cd ~

mkdir folder1

cd folder1

touch file1

touch file2

touch file3

touch file4

tar cvf archive.tar *

mkdir ../folder2

cd ../folder2

touch new_file

cp ../folder1/archive.tar .

tar rvf archive.tar new_file

tar vf archive.tar --delete file3

tar vf archive.tar --list > list1

tar vf ../folder1/archive.tar --list > list2

diff list1 list2

#Разъединение выполнить не получится, потому что все файлы пустые, но если засовывать не пустые, то

split -b 10M archive.tar "part" # вместо 10M нужный размер

cat part* > joined_archive.tar

tar vf archive.tar --list

tar vf joined_archive.tar --list

tar czvf final_archive.tar archive.tar ../folder1/archive.tar joined_archive.tar

0,0(0 оценок)
Ответ:
qwerty91a
qwerty91a
09.03.2020 15:06
Если у нас есть координаты этих вершин на плоскости вида (x; y), то
A(x1,y1)
B(x2,y2)
C(x3,y3)

program q;
var x1,x2,y1,y2,x3,y3:integer;
ab,ac,alp,bet,alfa,s:real;
begin
write('введите координаты точки A: ');
read(x1);
readln(y1);
write('введите координаты точки B: ');
read(x2);
readln(y2);
write('введите координаты точки C: ');
read(x3);
readln(y3);
ab:=sqrt(sqr(x2-x1)+sqr(y2-y1));
ac:=sqrt(sqr(x3-x1)+sqr(y3-y1));
alp:=arctan((y2-y1)/(x2-x1));
bet:=arctan((y3-y1)/(x3-x1));
alfa:=bet*2-alp;
s:=sin(alfa)*(ab*ac)/2;
writeln('площадь треугольника=',s);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота