В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
marta62
marta62
08.11.2020 10:36 •  Информатика

Написать программу на языке программирования высокого уровня с++ вычисляющую количество введенных чисел и максимальный элемент из входного потока. данные ввести с клавиатуры и записать во внешний файл на диске. количество введенных чисел не ограничено. признак окончания ввода чисел во входном потоке - число 421. после записи введенных данных в конец файла дописать количество введенных чисел и максимальное введенное число. например, количество введенных чисел - 12, максимальное среди введенных - 345, причем признак окончания ввода - последнее число 421 не учитывать.

Показать ответ
Ответ:
kubikrubik201
kubikrubik201
06.10.2020 14:40
#include <iostream>
#include <fstream>

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    std::ofstream file("file.txt");
    int cr=0;
    int max = 0;
    int count = 0;
    do
    {
        std::cout << "Введите число >> ";
        std::cin >> cr;
        if (cr > max)
            max = cr;
        if(cr!=421)
            file << cr << std::endl;
        count++;
    } while (cr != 421);
    file << "Количество введенных чисел: " << count << std::endl;
    file << "Максимальное введенное число: " << max << std::endl;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота