В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
beauty227
beauty227
24.05.2022 16:38 •  Информатика

Написать программу на языке Рascal для решения задачи: Ввести с клавиатуры значения 15 элементов массива, содержащего вещественные числа. Значение каждого элемента массива увеличить в 4 раза. Вывести значения элементов измененного массива на экран в столбик.

Показать ответ
Ответ:
адинаа1
адинаа1
09.12.2021 15:40

ответ:1. var

a:array[1..7] of integer;

i:Integer;

begin

//заполнение массива

a[1]:=3;

a[2]:=8;

a[3]:=2;

a[4]:=0;

a[5]:=2;

a[6]:=1;

a[7]:=7;

//вывод массива

for i:=1 to 7 do

Writeln(a[i]);

end.

2. var

c:array[1..12] of integer;

i:Integer;

begin

//заполнение массива

for i:=1 to 12 do

begin

Writeln('Введите ',i,' элемент массива');

readln(c[i]);

end;

//вывод массива

Writeln('Массив');

for i:=1 to 12 do

Write(c[i],' ');

end.

3.var

s:array[1..15] of integer;

i:Integer;

begin

//заполнение массива

for i:=1 to 15 do

s[i]:=random(40);

//вывод массива

Writeln('Массив');

for i:=1 to 15 do

Write(s[i],' ');

end.

4.var

b:array[1..25] of Real;

i:Integer;

begin

//заполнение массива

b[1]:=3;

b[2]:=6;

for i:=3 to 25 do

b[i]:=(b[i-1]+b[i-2])/i;

//вывод массива

Writeln('Массив');

for i:=1 to 25 do

Write(b[i]:9:3);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота